Owners of WordPress-based websites should update the Jetpack plug-in as soon as possible because of a serious flaw that could expose their users to attacks.
Jetpack is a popular plug-in that offers free website optimization, management and security features. It was developed by Automattic, the company behind WordPress.com and the WordPress open-source project, and has over 1 million active installations.
Researchers from Web security firm Sucuri have found a stored cross-site scripting (XSS) vulnerability that affects all Jetpack releases since 2012, starting with version 2.0.
“The vulnerability can be easily exploited via wp-comments and we recommend everyone to update asap, if you have not done so yet,” said Sucuri researcher Marc-Alexandre Montpas in a blog post.
Sites that don’t have the Shortcode Embeds module activated are not affected, but this module provides popular functionality so many websites are likely to have it enabled.
The Jetpack developers have worked with the WordPress security team to push updates to all affected versions through the WordPress core auto-update system.Jetpack versions 4.0.3 or newer contain the fix.
In case users don’t want to upgrade to the latest version, the Jetpack developers have also released point releases for all twenty-one vulnerable branches of the Jetpack codebase: 2.0.7, 2.1.5, 2.2.8, 2.3.8, 2.4.5, 2.5.3, 2.6.4, 2.7.3, 2.8.3, 2.9.4, 3.0.4, 3.1.3, 3.2.3, 3.3.4, 3.4.4, 3.5.4, 3.6.2, 3.7.3, 3.8.3, 3.9.7, and 4.0.3.